Fails to Deploy

Feb 3, 2010 at 1:28 PM

This is great; however, when I go to deploy and install the module from the built zip file that is in the deploy directory, I get the following error.  

Failure File specified in the dnn could not be found in the zip file: C:\inetpub\wwwroot\DNN5\Install\Temp\i2g5tijd\bin\MyCustomProjectAjax.dll

Where "i2g5tijd" in the temp directory appears to be random. When I look in the Temp folder, I do not even see this folder. I tried creating the temp folder it expects, but the next time I try to install the directory changes. 

It leads me to think that the unzip operation within the installation is not unpacking the contents of the zip, which includes the right dlls and module definition.  Is there something I am doing wrong? 

 

BTW, the build aspect of this is most intriguing.  

I appreciate the help.

Regards, Robert

Feb 3, 2010 at 2:13 PM

Actually, I was slightly mistaken.  The DLL that it is trying to reference isn't in the install ZIP, which leads me to believe the issue is now with the target file. Am I the only whose experienced this issue?

Feb 3, 2010 at 2:31 PM

I realized that the dnn target expected the assembly names to be (CompanyName).$(ModuleName).dll...my assemblies did not include the company name.  Once I changed my assemblynames to include what was expected this, I was able to successfully run http://mydnninstance/DNN5/install/install.aspx?mode=installresources.

Coordinator
Feb 4, 2010 at 1:37 PM

Glad to hear you got it figured out.