can't re-open skin project in VS2008

Mar 9, 2009 at 5:33 PM

First of all, THANKS for all of your hard work on this.  I am a dotnetnuke newbie with some experience in ASP.NET.  I was able to install the templates, build the skin, and install it into my dotnetnuke site.  This is the greatest thing since sliced bread, and I can't wait to get to the modules!

Now to my question.  When I go to re-open my skin project in VS2008, I get an error.  It says:

Unable to read the project file 'myProject.vbproj'.
(path to myproject)\DNNSkin.Targets(22,13):The imported project (it gives the path where my temp project was - not where I actually saved it)\lib\msbuild\MSBuildCommunityTasks\" was not found. . .

I checked in the DNNSkin.Target file and found where that path was.  The path was, of course, invalid.  I had no \lib\ folder in my skin OR dnn project.  I did a search and pointed it to where the file was located in \program files\msbuild\MSBuildCommunityTasks\

Then I got an error: "A project with that name is already opened in the solution"

Either way, my solution is 'unavailable' and cannot be loaded.

Can anyone point me in the right direction on this one???
Mar 10, 2009 at 5:03 PM

Problem solved, Jon replied to my post in the DNN skinning forums and it sparked me (also probably a fresh look at it today helped!)  This is the solution:

I have fixed the problem.  I will post the problem/solution here, and in the discussions page on codeplex in case anyone ever runs up against this!  (I hate searching for the solution to a problem only to find the exact question I'm looking for with a reply by the poster saying "Never mind, I fixed it.")  I am using XP, VS2008 SP1.

After reading your reply, and looking back at the path where VS was looking for the \lib folder, I realized it WAS creating that folder - in a temporary folder.  The DNNSkin.targets file was created based on those paths, and when I saved the project, it did not of course bring the \lib folder with it.  The fix for this is simple, there is an option  -- Options -> Projects and Solutions - "Save new projects when created" that needed checked.

Then I got a different error:  "A project with that name is already opened in the solution"

Google led me to this blog post:

I checked in the .vbproj file, and sure enough the ProjectTypeGuids were:


The first guid is for a web app, the second was for a c# app.  I had created the project based from the template under the VB Project Type, but the file had the wrong guid.  I just had to change that to the one for VB.NET {F184B08F-C81C-45F6-A57F-5ABD9991F28F}

Everything is great now!  Again, thanks Jon very much for your work.  You have simplified the lives of many!